Ребят решите задачи 1) Дан текст .Написать программу вставляющию после каждой запятой по одному пробелу. 2)Дан текст ,слова в тексте разделены одним и несколькими пробелами.Написатт программу выводящию все слова в алфавитном п...
Ребят решите задачи
1) Дан текст .Написать программу вставляющию после каждой запятой по одному пробелу.
2)Дан текст ,слова в тексте разделены одним и несколькими пробелами.Написатт программу выводящию все слова в алфавитном порядке.
Ответ(ы) на вопрос:
Гость
// PascalABC.NET 3.1, сборка 1230 от 27.04.2016
begin
var s:=ReadlnString('>');
s:=s.Replace(',',', '); Writeln(s);
Writeln(NewLine,'Список слов:');
s.ToWords.OrderBy(x->x).Println(NewLine);
end.
Тестовый пример
> Это мой,плохо форматированный,но зато мой текст!
Это мой, плохо форматированный, но зато мой текст!
Список слов:
зато
мой
мой,
но
плохо
текст!
форматированный,
Это
Гость
//Pascal ABC.NET v3.1 сборка 1172
//1
Var
s:string;
i:integer;
begin
readln(s);
while i' ') and (i<>length(s)) then inc(k) else ars[k]:=ars[k]+s[i];
end;
for i:=0 to k-1 do
for j:=i+1 to k do
if LowerCase(ars[i])>LowerCase(ars[j]) then
begin
s:=ars[i];
ars[i]:=ars[j];
ars[j]:=s;
end;
for i:=0 to k do
writeln(ars[i]);
end.
Пример ввода:
Очень много яков и антилоп
Пример вывода:
антилоп
и
много
Очень
яков
Не нашли ответ?
Похожие вопросы