Решить на C#, используя циклы.   Составить программу для вычисления и вывода n первых чисел Фибоначчи. Числа Фибоначчи получаются с помощью следующих рекуррентных соотношений [latex]f_{1}=f_{2}=1, f_{n}=f_{n-1}+f_{n-2}, n\geq3,...

Решить на C#, используя циклы.   Составить программу для вычисления и вывода n первых чисел Фибоначчи. Числа Фибоначчи получаются с помощью следующих рекуррентных соотношений [latex]f_{1}=f_{2}=1, f_{n}=f_{n-1}+f_{n-2}, n\geq3, [/latex]   где [latex]f_{n}[/latex]  - целое. Отследить корретность ввода исходных данных.
Гость
Ответ(ы) на вопрос:
Гость
using System; class Program { public static int Fibonacci(int n) { int a = 0; int b = 1; for (int i = 0; i < n; i++) { int temp = a; a = b; b = temp + b; } return a; } static void Main() { Console.Write("Введите N:"); int n = Int32.Parse(Console.ReadLine()); for (int i = 0; i < n; i++) { Console.WriteLine(Fibonacci(i)); } } }
Не нашли ответ?
Ответить на вопрос
Похожие вопросы