Составить блок-схему и написать программу на БЕЙСИКЕ.в одномерном массиве состоящем из n целых элементов вычислить сумму квадратов всех нечетных чисел
Составить блок-схему и написать программу на БЕЙСИКЕ.в одномерном массиве состоящем из n целых элементов вычислить сумму квадратов всех нечетных чисел
Ответ(ы) на вопрос:
uses crt;
var n,i,ans:integer;
a:array[1..100] of integer;
begin
writeln('Введите n и элементы массива.');
read(n);
for i:=1 to n do
begin
read(a[i]);
if a[i] mod 2 <>0 then
ans:=ans+sqr(a[i]);
end;
writeln(ans);
end.
Не нашли ответ?
Похожие вопросы