Составить программу для нахождения количества таких трехзначных чисел Фибоначчи
Составить программу для нахождения количества таких трехзначных чисел Фибоначчи, которые делятся на сумму своих цифр нацело. Программа - Pascal ABC
Ответ(ы) на вопрос:
Var
a,b,k,s: integer;
begin
k := 0;
a := 1;
b := 1;
while b < 1000 do
begin
if b >= 100 then
begin
s := b div 100 + b div 10 mod 10 + b mod 10;
if b mod s = 0 then
k := k + 1
end;
b := a + b;
a := b - a;
end;
write(k)
end.
Не нашли ответ?
Похожие вопросы