Составить программу для решения следующей задачи: Дан массив целых чисел, заполненный случайными числами в диапазоне [-100, 100]. Замените все отрицательные элементы максимальным. Выведите на экран исходный и измененный массивы.
Составить программу для решения следующей задачи: Дан массив целых чисел, заполненный случайными числами в диапазоне [-100, 100]. Замените все отрицательные элементы максимальным. Выведите на экран исходный и измененный массивы.
Ответ(ы) на вопрос:
var
i,max:integer;
ar:array[0..200] of integer;
begin
randomize;
max:=0;
for i:=1 to 200 do begin
ar[i]:=random(200+1)-100;
if (ar[i] > max) then max:=ar[i];
if (i mod 20=0) then writeln(ar[i]) else write(ar[i],' ');
end;
writeln();
for i:=1 to 200 do begin
if (ar[i] < 0) then ar[i]:=max;
if (i mod 20=0) then writeln(ar[i]) else write(ar[i],' ');
end;
end.
Не нашли ответ?
Похожие вопросы