Составить программу, которая печатает true, если точка с координатами (X, Y) принадлежит к заштрихованной области, и false в противном случае.

Составить программу, которая печатает true, если точка с координатами (X, Y) принадлежит к заштрихованной области, и false в противном случае.
Гость
Ответ(ы) на вопрос:
Гость
Уравнение прямой, ограничивающей область сверху: y1 = 1 y = 5 x1 = 5 x = 2 k = (y - y1) / (x - x1) y = y1 +k(x-x1) k = (5-1)/(2-5) = -4/3 y =1-4/3*(x-5) Снизу: x1 = 2 x = 5 y1 = -4 y = 1 k = 5/3 y = -4 +5/3*(x-2) И слева: x = 2 Код PascalABC.NET 3.2: Var x,y:real; Begin Write('x = ');ReadLn(x); Write('y = ');ReadLn(y); Write((y<=1-4/3*(x-5))and(y>=-4+5/3*(x-2))and(x>=2)) End.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы