Составить программу, которая подсчитывает количество четных чисел,количество нечетных чисел, сумму и среднее арифметическое в последовательности которая закачивает 0

Составить программу, которая подсчитывает количество четных чисел,количество нечетных чисел, сумму и среднее арифметическое в последовательности которая закачивает 0
Гость
Ответ(ы) на вопрос:
Гость
Program n1; var a,kch,knc,k,sum: integer; begin write('введите 1 член последовательности: '); readln(a); knc:=0; sum:=0; kch:=0; k:=0; while a<>0 do begin k:=k+1; if a mod 2=0 then kch:=kch+1 else knc:=knc+1; sum:=sum+a; write('введите следущий член: '); readln(a); end; writeln('сумма: ',sum); writeln('кол-во четных: ',kch); writeln('кол-во нечетных: ',knc); writeln('ср. арифмитическое: ',sum/k); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы