Составить программу PASCAL - калькулятор, которая запрашивает тип арифметической операции: 1-сложение, 2-вычитание, 3 - умножение, 4 - деление, а также два числа и производит над ними соответствующую арифметическую операцию. Вв...
Составить программу PASCAL - калькулятор, которая запрашивает тип арифметической операции: 1-сложение, 2-вычитание, 3 - умножение, 4 - деление, а также два числа и производит над ними соответствующую арифметическую операцию. Ввод чисел заканчивается нажатием клавиши 0. Протокол работы программы: Выберите тип арифметической операции: 1-сложение, 2-вычитание, 3 - умножение, 4 - деление, 0 - выход. 1 Введите два числа: 15 16 Ответ: 15+16=31 Выберите тип арифметической операции: 1-сложение, 2-вычитание, 3 - умножение, 4 - деление, 0 - выход. 3 Введите два числа: 5 8 Ответ: 5*8=40 Выберите тип арифметической операции: 1-сложение, 2-вычитание, 3 - умножение, 4 - деление, 0 - выход. 0 Пока!
Ответ(ы) на вопрос:
Гость
Var A,B:real;
C:integer;
Begin
WriteLn('1 - сложение, 2 - вычитание, 3 - умножение, 4 - деление, 0 - выход');
ReadLn(C);
While C <> 0 do
Begin
Write('Введите два числа: ');
ReadLn(A,B);
Write('Ответ: ');
Case C of
1:WriteLn(A+B);
2:WriteLn(A-B);
3:WriteLn(A*B);
4:WriteLn(A/B);
End;
WriteLn('1 - сложение, 2 - вычитание, 3 - умножение, 4 - деление, 0 - выход');
ReadLn(C);
End;
WriteLn('Пока!');
End.
Вывод результат, точно как в условии:
Var A,B:real;
C:integer;
Begin
WriteLn('1 - сложение, 2 - вычитание, 3 - умножение, 4 - деление, 0 - выход');
ReadLn(C);
While C <> 0 do
Begin
Write('Введите два числа: ');
ReadLn(A,B);
Write('Ответ: ');
Case C of
1:
if B < 0 then WriteLn(A,B,'=',A+B)
else WriteLn(A,'+',B,'=',A+B);
2:
if B < 0 then WriteLn(A,'+',-B,'=',A-B)
else WriteLn(A,B,'=',A-B);
3:
if B < 0 then WriteLn(A,'*(',B,')=',A*B)
else WriteLn(A,'*',B,'=',A*B);
4:
if B < 0 then WriteLn(A,':(',B,')=',A/B)
else WriteLn(A,':',B,'=',A/B);
End;
WriteLn('1 - сложение, 2 - вычитание, 3 - умножение, 4 - деление, 0 - выход');
ReadLn(C);
End;
WriteLn('Пока!');
End.
Пример:
1 - сложение, 2 - вычитание, 3 - умножение, 4 - деление, 0 - выход
4
Введите два числа: 4
-2.5
Ответ: 4:(-2.5)=-1.6
1 - сложение, 2 - вычитание, 3 - умножение, 4 - деление, 0 - выход
1
Введите два числа: -3
-6
Ответ: -3-6=-9
1 - сложение, 2 - вычитание, 3 - умножение, 4 - деление, 0 - выход
0
Пока!
Не нашли ответ?
Похожие вопросы