Составить программу в паскале с использованием циклических операторов: найти все натуральные решения уравнения х^2+у^2=М, где М больше 0 задает пользователь
Составить программу в паскале с использованием циклических операторов:
найти все натуральные решения уравнения х^2+у^2=М, где М>0 задает пользователь
Ответ(ы) на вопрос:
var
x, y, m: integer;
begin
readln(m);
writeln('x':6, 'y':6);
for x := 0 to m do
for y := 0 to m do
if (sqr(x) + sqr(y) = m) then
writeln(x:6, y:6);
end.
Не нашли ответ?
Похожие вопросы