Составить программу вычисления значения функций в зависимости от интервала у=1+3х, при х меньше -2 1+xв квадрате, при -2 меньше _x меньше _2 (x+1), при x больше 2
Составить программу вычисления значения функций в зависимости от интервала у=1+3х, при х<-2 1+xв квадрате, при -2<_x<_2 (x+1), при x>2
Ответ(ы) на вопрос:
var x,y:real;
begin
writeln ('Введите x');
readln (x);
if (x<-2) then y:=1+3*x;
if (x>=-2) and (x<=2) then y:=sqr(1+x); //по условию -2<_x<_2 я подумал, что _ значит =, если нет - удали равно здесь (x>=-2) and (x<=2)
if (x>2) then y:=x+1;
writeln ('Значение функции = ',y);
end.
Не нашли ответ?
Похожие вопросы