Составьте программу решения квадратного уравнения ax(Во второй степени) + bx + c = 0. Коэффициенты a,b,c введите с клавиатуры. Выведите на экран значение корней x1,x2, если уравнение имеет два корня, значение x, если уравнение ...
Составьте программу решения квадратного уравнения ax(Во второй степени) + bx + c = 0. Коэффициенты a,b,c введите с клавиатуры. Выведите на экран значение корней x1,x2, если уравнение имеет два корня, значение x, если уравнение имеет один корень, или сообщение "Нет корней" , если уравнение не имеет корней.
Составьте программу на уровне 8 класса.
Ответ(ы) на вопрос:
var
a, b, c: real;
begin
readln(a, b, c);
if (sqr(b) - 4 * a * c < 0) then
writeln('Нет решений')
else
if (sqr(b) - 4 * a * c = 0) then
writeln('x = ', (-1 * b) / (2 * a))
else
begin
writeln('x1 = ', (-1 * b + sqrt(sqr(b) - 4 * a * c)) / (2 * a));
writeln('x2 = ', (-1 * b - sqrt(sqr(b) - 4 * a * c)) / (2 * a));
end;
end.
Не нашли ответ?
Похожие вопросы