Составьте программу ввода с клавиатуры массива целых чисел a[1..10] и вывода на экран элементов массива с четными положительными значениями.
Составьте программу ввода с клавиатуры массива целых чисел a[1..10] и вывода на экран элементов массива с четными положительными значениями.
Ответ(ы) на вопрос:
var a: array[1..10] of integer;
i:integer;
begin
for i:=1 to 10 do
begin
readln(a[i]);
if (a[i] mod 2 = 0) and (a[i] > 0) then writeln ('Положительное и четное: ', a[i]);
end;
end.
//Программа проверяет каждое число при вводе, т.е. если введённое число является положительным и четным, то программа его сразу же выводит.
Не нашли ответ?
Похожие вопросы