Составьте программу, выводящую на экран все четырехзначные числа, сумма цифр которых меньше 4 паскаль
Составьте программу, выводящую на экран все четырехзначные числа, сумма цифр которых меньше 4
паскаль
Ответ(ы) на вопрос:
Гость
var s:string;
begin
for var i:=1000 to 9999 do
begin
s:=i.ToString;
if((strtoint(s[1])+strtoint(s[2])+strtoint(s[3])+strtoint(s[4]))<4)then write(i,' ');
end;
end.
Не нашли ответ?
Похожие вопросы