(!!! СРОЧНО, МНОГО БАЛЛОВ !!!) Pascal ABC, написать программу: Дан целочисленный одномерный массив, состоящий из n элементов, и натуральные числа k, m (k МЕНЬШЕ m МЕНЬШЕ n). Вычислить среднее арифметическое элементов массива с ...
(!!! СРОЧНО, МНОГО БАЛЛОВ !!!) Pascal ABC, написать программу: Дан целочисленный одномерный массив, состоящий из n элементов, и натуральные числа k, m (k МЕНЬШЕ m МЕНЬШЕ n). Вычислить среднее арифметическое элементов массива с номерами от k до m включительно.
Ответ(ы) на вопрос:
Гость
const n=100;
var
a: array [1,n] of integer;
sr:real; k, m, sum, i : integer;
begin
for i:= 1 to n do a[i]:=ranfom(100);
readln (k);
readln (m);
sum = 0;
for i:=k to m do
sum:=sum+a[i];
sr := sum/(m - k + 1);
writeln (sr);
end.
Не нашли ответ?
Похожие вопросы