Срочно! Написать в Pascal ABC Дано N чисел. Найти самое большое число, на которое делятся все N чисел. Входные данные В первой строке дано число N. Во второй строке даны через пробел N чисел (1 меньше = N меньше = 1000). Вых...

Срочно! Написать в Pascal ABC Дано N чисел. Найти самое большое число, на которое делятся все N чисел. Входные данные В первой строке дано число N. Во второй строке даны через пробел N чисел (1 <= N <= 1000). Выходные данные Выведите искомое число
Гость
Ответ(ы) на вопрос:
Гость
var  a: array of integer;            i, n, x, digit: integer;         b1, b2: boolean; begin     readln(n);    setlength(a, n);    for i := 0 to n - 1 do readln(a[i]);    b1 := true;    x := 1;    digit := x;    while b1 do   begin        if b2 then digit := x;        inc(x);        b2 := true;        for i := 0 to n - 1 do begin            if (abs(a[i]) < x) and (a[i] <> 0) then begin b1 := false;break; end            else if a[i] mod x <> 0 then begin b2 := false;break; end        end;    end;    write(digit); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы