ТЕМА: МАССИВЫпомогите плиз!Написать программу расчета среднего арифметического отрицательных элементов в одномерном массиве. Заменить минимальный элемент в одномерном массиве на полученное среднее арифметическое.
ТЕМА: МАССИВЫ
помогите плиз!
Написать программу расчета среднего арифметического отрицательных элементов в одномерном массиве. Заменить минимальный элемент в одномерном массиве на полученное среднее арифметическое.
Ответ(ы) на вопрос:
var
i,n:integer;
s,min:real;a:array[1..10]of real;
begin
writeln('Исходный массив:');
for i:=1 to 10 do
begin
a[i]:=random(-10,10);
write(a[i],' ');
if a[i]<0 then
begin
s:=s+a[i];
n:=n+1;
end;
if a[i]
Не нашли ответ?
Похожие вопросы