Требуется отсортировать массив по неубыванию методом "пузырька".    В первой строке вводится одно натуральное число, не превосходящее 1000 – размер массива. Во второй строке задаются Nчисел – элементы массива (целые числа, не п...

Требуется отсортировать массив по неубыванию методом "пузырька".     В первой строке вводится одно натуральное число, не превосходящее 1000 – размер массива. Во второй строке задаются Nчисел – элементы массива (целые числа, не превосходящие по модулю 1000). НА С++ Пожалуйста!!!
Гость
Ответ(ы) на вопрос:
Гость
a:array[1..1000] of integer; i, k, z, n, j:integer; begin readln(n); for i:=1 to n do readln(a[i]); for i:=1 to n-1 do for j:=1 to n-i do if a[j]>a[j+1] then begin z:=a[j]; a[j]:=a[j+1]; a[j+1]:=z; end; for i:=1 to n do writeln(a[i]); readln; end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы