В классе 7 учеников, известны результаты сдачи экзаменов по двум предметам. Составьте программу вычисления количества учащихся, сдавщих оба экзамена на отлично. Вывести на экран исходную матрицу-ведомость, результаты подсчета и...
В классе 7 учеников, известны результаты сдачи экзаменов по двум предметам. Составьте программу вычисления количества учащихся, сдавщих оба экзамена на отлично. Вывести на экран исходную матрицу-ведомость, результаты подсчета и средний балл по каждому предмету. ПАСКАЛЬ
Ответ(ы) на вопрос:
Гость
program u;
var i,j,k:integer;
b:array[1..7] of string;
a:array[1..7,1..3] of real;
begin
k:=0;
writeln('запишите фамилии учеников в столбик');
for i:=1 to 7 do readln(b[i]);
for i:=1 to 7 do writeln(b[i]);for i:=1 to 7 do begin writeln('запишите оценки' , b[i]);
for j:=1 to 2 do read (a[i,j]);end;
for i:=1 to 7 do a[i,3]:=(a[i,1]+a[i,2])/2 ;
for i:=1 to 7 do begin writeln;write(b[i],' ',45a[i,1],' ',a[i,2],' средняя оценка ',a[i,3]);end;
writeln;for i:=1 to 7 do if (a[i,1]=5) and (a[i,2]=5)then k:=k+1;
writeln('количество отличников ',k);
end.
Не нашли ответ?
Похожие вопросы