В Турбо паскале Уже нужно Составить программу для обработки массива содержащего 10 целых числе. Определить максимальный элемент массива. Выполнение каждого логического блока программы оформить в виде отдельных процедур

В Турбо паскале Уже нужно Составить программу для обработки массива содержащего 10 целых числе. Определить максимальный элемент массива. Выполнение каждого логического блока программы оформить в виде отдельных процедур
Гость
Ответ(ы) на вопрос:
Гость
uses crt; var i,j,k,n,max:integer; a:array[1..100] of integer; procedure rmassr; begin     for i:=1 to n do     a[i]:=random(10); end; procedure rmassy; begin     for i:=1 to n do     readln(a[i]); end; procedure maxe; begin max:=a[1];     for i:=2 to n do begin         if a[i] > max then max:=a[i];     end;     writeln('max element = ', max); end; procedure wmass; begin     for i:=1 to n do     write(a[i],' ');     writeln; end; begin clrscr; randomize; write('Длина массива'); readln(n); write('1-random; 2- в ручную '); readln(k); if k=1 then rmassr() else rmassy(); wmass(); maxe(); readln end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы