Вычислить и напечатать значение функции y=x^3-3x^2+9 для x от -1 до 8 с шагом 0,7 написать программу в Паскале.
Вычислить и напечатать значение функции y=x^3-3x^2+9 для x от -1 до 8 с шагом 0,7 написать программу в Паскале.
Ответ(ы) на вопрос:
const h=0.7;
var a, b, x, y: real;
begin
writeln(' [-1,8] s shagom 0.7 ');
a:=-1;
b:=8;
writeln('--------------------------');
writeln('| X | Y |');
writeln('--------------------------');
x:= a;
while x<= b do begin
y:=(x*x*x)-sqr(3*x)+9;
writeln('|', x:9:2, ' |' , y:9:2, ' |');
x:= x+h;
end;
writeln('--------------------------');
end.
Не нашли ответ?
Похожие вопросы