Задача 1. Написать программу вывода первых t элементов одномерного массива из 10 элементов, введенных с клавиатуры Задача 2. Написать программу формирования значений элементов одномерного массива с использованием генератора слу...

Задача 1. Написать программу вывода первых t элементов одномерного массива из 10 элементов, введенных с клавиатуры Задача 2. Написать программу формирования значений элементов одномерного массива с использованием генератора случайных чисел в интервале от -10 до 10 (функция random). Количество элементов массива 10. Вычислить среднее значение неположительных элементов. Задача 3. Написать программу формирования значений элементов одномерного массива в произвольном интервале целых чисел (ввод с клавиатуры). Количество элементов массива 10. Выписать индексы положительных элементов массива, кратных 3. Задача 4. Даны два одномерных массива из целых чисел разной размерности. Найти целую часть среднего арифметического элементов каждого массива и их сумму. Задача 5. Заполните массив из N элементов случайными числами в интервале [1,N] так, чтобы в массив обязательно вошли все числа от 1 до N (постройте случайную перестановку). Пример: Массив: 3 2 1 4 5
Гость
Ответ(ы) на вопрос:
Гость
Такое задание уже было. Я на него отвечал, думаю модераторы не против, если свой же ответ здесь предоставлю)   Только первых три Задача 1: var p: array[1..10] of integer;   i:integer; count:integer; begin for i:=1 to 10 do read(p[i]); write('Сколько цифр массива хотите видеть? -> ');  readln(count); for i:=1 to count do write(p[i]:3); end. Задача 2: var arr: array[1..10] of integer;    i:integer;     s:integer;     count:integer; begin for i:=1 to 10 do begin arr[i]:=Random(-10,10); if(arr[i]<0) then begin writeln(arr[i]:4); s:=s+arr[i]; count:=count+1; end; end; writeln('Среднее значение = ', s/count); end. Задача 3: var arr: array[1..10] of integer;     i:integer;     crat:integer;     id:integer;        begin    for i:=1 to 10 do    begin    read(arr[i]);    crat:=arr[i] mod 3;    if(crat = 0) then    begin    id:=arr[i];      if(arr[i] = id) then writeln('Id = ', i:2);     end;    end;    end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы