Задача №308. Исключающее ИЛИ Напишите функцию function _Xor (x, y:boolean): boolean (Pascal) Входные данные Вводится 2 числа - x и y (x и y равны 0 или 1, 0 соответствует значению false, 1 соответствует значению true). Выходны...

Задача №308. Исключающее ИЛИ Напишите функцию function _Xor (x, y:boolean): boolean (Pascal) Входные данные Вводится 2 числа - x и y (x и y равны 0 или 1, 0 соответствует значению false, 1 соответствует значению true). Выходные данные Необходимо вывести 0 или 1 - значение функции от x и y. выодные 0 1 выходные 1 Хелп
Гость
Ответ(ы) на вопрос:
Гость
//PascalABC.Net 3.2 function f_xor(x, y: integer):=(x+y) mod 2; begin write (f_xor(readinteger('x ='), readinteger('y ='))); end.
Гость
function _Xor (x, y:boolean): boolean; begin _Xor:=not(x=y); end; var x,y:integer; begin write('x y: '); readln(x,y); if _Xor(x=0,y=0)  then writeln(1) else writeln(0); end. Пример: x y: 0 1 1
Не нашли ответ?
Ответить на вопрос
Похожие вопросы