Задача:Дан массив из 10 целых чисел,от -20 до 20 .Напишите программу,заменяющую первый отрицательный элемент массива нулем.Помогите пожалуйста решить!

Задача: Дан массив из 10 целых чисел,от -20 до 20 . Напишите программу,заменяющую первый отрицательный элемент массива нулем. Помогите пожалуйста решить!
Гость
Ответ(ы) на вопрос:
Гость
var a:array [1..10] of integer;      i,n,b:integer; Begin   for i:=1 to 10 do     read(a[i]);   for i:=1 to 10 do   begin     if b=0 then if a[i]<0 then         begin          a[i]:=0;          b:=1;        end;   end;   for i:=1 to 10 do   write(a[i],' '); End.
Гость
Program z10; var a,b:Array [1..10] of integer; i,q:integer; Begin Randomize; q:=0; For i:=1 to 10 do begin a[i]:=random(40)-20; write(a[i],' '); if(a[i]<0)then begin q:=q+1; if(q=1)then a[i]:=0; end; end; writeln; for i:=1 to 10 do begin write(a[i],' '); end; end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы