5. Составьте программу сортировки по возрастанию значений в трех переменных: А, В, С. 6. Составьте программу вычисления корней квадратного уравнения по данным значениям его коэффициентов. НЕ ИЗ ИНТЕРНЕТА!!
5. Составьте программу сортировки по возрастанию значений в трех переменных: А, В, С.
6. Составьте программу вычисления корней квадратного уравнения по данным значениям его коэффициентов.
НЕ ИЗ ИНТЕРНЕТА!!
Ответ(ы) на вопрос:
Гость
Var
A,B,C:integer;
Begin
WriteLn('Введите три числа');
ReadLn(A,B,C);
if (A<=B)and(B<=C) then Write(A,' ',B,' ',C)
else if (A<=C)and(C<=B) then Write(A,' ',C,' ',B)
else if (B<=A)and(A<=C) then Write(B,' ',A,' ',C)
else if (B<=C)and(C<=A) then Write(B,' ',C,' ',A)
else if (C<=A)and(A<=B) then Write(C,' ',A,' ',B)
else if (C<=B)and(B<=A) then Write(C,' ',B,' ',A)
End.
Var a,b,c,D:real;
Begin
Write('a = ');ReadLn(a);
Write('b = ');ReadLn(b);
Write('c = ');ReadLn(c);
D:=b*b-4*a*c;
if D>=0 then
Begin
WriteLn('x = ',(-b-sqrt(D))/(2*a));
WriteLn('x = ',(-b+sqrt(D))/(2*a));
End
else WriteLn('Действительных корней нет')
End.
Не нашли ответ?
Похожие вопросы