Даны два одномерных массива из целых чисел разной размерности. Найти целую часть среднего арифметического элементов каждого массива и их сумму. Помогите написать программу в паскале.
Даны два одномерных массива из целых чисел разной размерности. Найти целую часть среднего арифметического элементов каждого массива и их сумму. Помогите написать программу в паскале.
Ответ(ы) на вопрос:
const
n=5;m=7;
var
a:array[1..n]of integer;
b:array[1..m]of integer;
s,s2:real;
i:integer;
begin
for i:=1 to n do
begin
a[i]:=random(50);
write(a[i]:4);
s:=s+a[i];
end;
writeln;
writeln(': ',trunc(s/n));
for i:=1 to m do
begin
b[i]:=random(70);
write(b[i]:4);
s2:=s2+b[i];
end;
writeln;
writeln(': ',trunc(s2/m));
writeln;
writeln('s: ',trunc(s/n)+trunc(s2/m));
end.
Не нашли ответ?
Похожие вопросы