Даны два целых числа a и b. Напишите программу, которая находит среднее арифметическое квадратов всех целых чисел от a до b Входные данные: В первой строке вводятся два целых числа a и b (a меньше =b, a,b не больше 100 по моду...

Даны два целых числа a и b. Напишите программу, которая находит среднее арифметическое квадратов всех целых чисел от a до b Входные данные: В первой строке вводятся два целых числа a и b (a<=b, a,b не больше 100 по модулю) Выходные данные: Программа должна вывести одно число - среднее арифметическое квадратов всех целых чисел от a до b (c 2 знаками после запятой) в c++
Гость
Ответ(ы) на вопрос:
Гость
#include using namespace std; int main() {     int a,b,n = 0;     float S = 0;     cin >> a;     cin >> b;          for(int i = a; i <= b; i++)     {          n++;          S+=i*i;     }     S = S/n;     cout.setf(ios::fixed);     cout.precision(2);     cout << "S = " << S << endl;     return 0; }
Не нашли ответ?
Ответить на вопрос
Похожие вопросы