Классе 20 учеников писали диктант по русскому языку Напишите программу подсчитывающую количество двоек троек четверок и пятерок полученным за диктант
Классе 20 учеников писали диктант по русскому языку Напишите программу подсчитывающую количество двоек троек четверок и пятерок полученным за диктант
Ответ(ы) на вопрос:
var
a:array [1..20] of integer;
d, t, c, p: integer;
begin
d:=0; t:=0; c:=0; p:=0;
for i:=1 to 20 do begin
writeln('Введите оценку');
read(a[i]);
if a[i]=2 then d:=d+1;
if a[i]=3 then t:=t+1;
if a[i]=4 then c:=c+1;
if a[i]=5 then p:=p+1;
end;
writeln('Пятерок -', ' ', p);
writeln('Четвёрок -', ' ', c);
writeln('Троек -', ' ', t);
writeln('Двоек -', ' ', d);
end.
Не нашли ответ?
Похожие вопросы