Массив из 5 элементов заполняется целыми числами. Составьте программу, которая вычисляет количество пар элементов, у которых один элемент - нечетный, а модуль второго меньше 5. Парой элементов считаются два рядом стоящие элемента.

Массив из 5 элементов заполняется целыми числами. Составьте программу, которая вычисляет количество пар элементов, у которых один элемент - нечетный, а модуль второго меньше 5. Парой элементов считаются два рядом стоящие элемента.
Гость
Ответ(ы) на вопрос:
Гость
Const N = 5; Var A:array[1..N] of integer; i,k:integer; Begin Write('Исходный массив: '); For i:= 1 to N do     Begin     A[i]:=random(21)-10;     Write(A[i],' ');     End; WriteLn; k:=0; For i:= 1 to N-1 do     if ((A[i] mod 2 <> 0)and(abs(A[i+1])<5))     or((A[i+1] mod 2 <> 0)and(abs(A[i])<5)) then k:=k+1; WriteLn(k) End.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы