Написать программу для определения количества и суммы только положительных чисел из 3, введенных с клавиатуры, на pascal

Написать программу для определения количества и суммы только положительных чисел из 3, введенных с клавиатуры, на pascal
Гость
Ответ(ы) на вопрос:
Гость
program ex; var a,b,c,s,k:integer; begin  writeln('Введите первое число');  readln(a);  writeln('Введите первое второе');  readln(b);  writeln('Введите первое третье');  readln(c);  if a>0 then  begin   k:=k+1;   s:=a;  end;  if b>0 then   begin    s:=s+b;    k:=k+1;   end;  if c>0 then   begin    k:=k+1;    s:=s+c   end; writeln('Сумма=',s); writeln('Количество положительных чисел=',k) end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы