Написать программу в PascalABC!!!Число в двоичной системе счисления, введенное пользователем программы, преобразовать в десятичное число.
Написать программу в PascalABC!!!
Число в двоичной системе счисления, введенное
пользователем программы, преобразовать в десятичное число.
Ответ(ы) на вопрос:
var a:string;
i,a1,ar:integer;b:real;
begin
readln(a);
b:=0;
for i:=1 to length(a) do
begin
val(a[length(a)-i+1],a1,ar);
b:=b+a1*exp((i-1)*ln(2));
end;
writeln('b=',b);
end.
Не нашли ответ?
Похожие вопросы