Написать программу, запрашивающую с клавиатуры целые числа и определяю-щую максимальное и минимальное из них. Окончание ввода – число 0. Протестиро-вать программу для последовательности: -3 5 6 -11 24 -1 0. ПАСКАЛЬ

Написать программу, запрашивающую с клавиатуры целые числа и определяю-щую максимальное и минимальное из них. Окончание ввода – число 0. Протестиро-вать программу для последовательности: -3 5 6 -11 24 -1 0. ПАСКАЛЬ
Гость
Ответ(ы) на вопрос:
Гость
uses crt; var x,min,max:integer; begin clrscr; min:=0;max:=0; Writeln('Write x = '); readln(x); min:=x; max:=x; while x<>0 do begin readln(x); if ((min > x) and (x<>0)) then min:=x; if ((max < x) and (x<>0)) then max:=x; end; writeln('max = ',max); writeln('min = ',min); readln end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы