Напишите программу, которая работает с двумя целыми числами, введёнными с клавиатуры. Программа выводит все чётные числа, расположенные в интервале между двумя введёнными числами. Например, пользователь вводит числа 10 и 20, пр...
Напишите программу, которая работает с двумя целыми числами, введёнными с клавиатуры. Программа выводит все чётные числа, расположенные в интервале между двумя введёнными числами. Например, пользователь вводит числа 10 и 20, программа выводит «12 14 16 18», если -8 и -3, то «-6 –4». Если пользователь вводит, например, числа 6 и 8, программа ничего не выводит. Точно так же программа ничего не выводит, если введённые числа равны, или второе указанное число меньше первого.
Ответ(ы) на вопрос:
Гость
begin
var
int one, two;
bool end=false;
readln(one)
readln(two)
if(one=two or one+2=two or one>two)
writwln("пара чисел написана неправильно")
while(end=false)
begin
if (two>one)
begin
one:=one+2;
writeln(one)
else
end=true;
end;
end;
end.
Не нашли ответ?
Похожие вопросы