Напишите программу, которая в последовательности целых чисел определяет количество двузначных чисел, кратных 5. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивает...

Напишите программу, которая в последовательности целых чисел определяет количество двузначных чисел, кратных 5. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30000. Программа должна вывести одно число: количество двузначных чисел, кратных 5. Пожалуйста помогите!
Гость
Ответ(ы) на вопрос:
Гость
Program n1; var a,k: integer; begin readln(a); k:=0; while a<>0 do begin if (a>9) and (a<100) and (a mod 5=0) then k:=k+1; readln(a); end; write(k); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы