Напишите программу, в которой осуществляется ввод целых чисел (пока не будет введён 0) и выведет на экран сумму положительных чисел, и произведение отрицательных введённых чисел. Использовать цикл repeat
Напишите программу, в которой осуществляется ввод целых чисел (пока не будет введён 0) и выведет на экран сумму положительных чисел, и произведение отрицательных введённых чисел. Использовать цикл repeat
Ответ(ы) на вопрос:
Гость
Program n1;
var a,i,p,sum: integer;
begin
sum:=0;
p:=1;
repeat
readln(a);
if a>0 then sum:=sum+a;
if a<0 then p:=p*a;
until (a=0);
writeln('произведение отрицательных: ',p);
writeln('сумма положительных: ',sum);
end.
Не нашли ответ?
Похожие вопросы