Очень срочно нужно написать программу! Помогите пожалуйста. Заданный текст содержит только буквы и цифры. Определить, обладает ли он следующим свойством: текст является восьмеричной записью числа, костного 5.
Очень срочно нужно написать программу! Помогите пожалуйста.
Заданный текст содержит только буквы и цифры. Определить, обладает ли он следующим свойством: текст является восьмеричной записью числа, костного 5.
Ответ(ы) на вопрос:
Гость
// PascalABC.NET 3.2, сборка 1389 от 01.03.2017
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadlnString('Вводите:');
if s=s.Where(s->s in ['0'..'7']).JoinIntoString then begin
var n:BigInteger=0;
var p:Biginteger:=1;
for var i:=s.Length downto 1 do begin
n:=n+(s[i].ToDigit)*p;
p*=8
end;
if n mod 5=0 then
Writeln('Текст является записью восьмеричного числа, кратного 5')
else Writeln('Текст является записью восьмеричного числа, не кратного 5')
end
else Writeln('Текст не является записью восьмеричного числа')
end.
Пример
Вводите: 26343553
Текст является записью восьмеричного числа, кратного 5
Не нашли ответ?
Похожие вопросы