Паскаль, срочно Напишите программу, которая определяет правильность записи целого числа в восьмеричной системе счисления. Формат входных данных На вход программы поступает символьная строка. Формат выходных данных Программа до...
Паскаль, срочно
Напишите программу, которая определяет правильность записи целого числа в восьмеричной системе счисления.
Формат входных данных
На вход программы поступает символьная строка.
Формат выходных данных
Программа должна вывести ответ 'YES', если строка представляет собой правильную запись целого числа в восьмеричной системе счисления, и 'NO', если запись ошибочна.
Примеры
входные данные выходные данные
12345
YES
Ответ(ы) на вопрос:
Гость
// PascalABC.NET 3.2, сборка 1383 от 09.02.2017
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadlnString;
if s.MatchValue('[0-7]*')=s then Writeln('YES')
else Writeln('NO')
end.
Не нашли ответ?
Похожие вопросы