Помогите, пожалуйста, написать программу на языке С++. Дано натурально число А в д

Помогите, пожалуйста, написать программу на языке С++. Дано натурально число А в десятичной системе счисления. Если все цифры числа А различные, то вывести на экран сообщение "Да", иначе - сообщение "Нет".
Гость
Ответ(ы) на вопрос:
Гость
#include <iostream> using namespace std; int main() {     int a;     int k[9];     bool f = true;     cout << "a = ", cin >> a, cout << "\n";     for (int i=0; i<10; i++) k[i]=0;     while (a>0){     k[a % 10]++;     a = a / 10;     }     for (int i=0; i<10; i++){     if (k[i]>1) f = false;     }     if (f) cout << "Да" << "\n";     else cout << "Нет" << "\n";     return 0; } Пример: a = 12523 Нет
Не нашли ответ?
Ответить на вопрос
Похожие вопросы