Помогите пожалуйста решить три задачки по информатике за 9й класс. 1) Напишите программу нахождения суммы денег вырученных от продажи газет B, если он зарабатывает А рублей на продажей каждой газеты. Кол-во газет и цена штуки ...
Помогите пожалуйста решить три задачки по информатике за 9й класс.
1) Напишите программу нахождения суммы денег вырученных от продажи газет B, если он зарабатывает А рублей на продажей каждой газеты. Кол-во газет и цена штуки вводятся вручную с клавиатуры.
2) Напишите программу вычисления сторон треугольника a, b, c, если треугольник задан координатами вершин (х1:y1), (x2:y2), (x3:y3) длинна стороны вычисляется по формуле a = √(х2-х1)^2 +√(y2-y1)^2
3) Третья задачка будет фотографией, если тут можно прикреплять файл вообще ))
Заранее огромное спасибо и + вам в карму )
Ответ(ы) на вопрос:
Гость
1)program сумма;
var
a, b, c: integer;
begin
writeln('Введите кол-во проданных газет.');readln(a);writeln('Введите цену одной газеты.');readln(b);writeln('Cумма денег, вырученных от продажи газет, равна ', a*b);
end.----------------------------------------------------------------------------------------------------
2)program нахождениесторонтреугольника;var x1,x2,x3,y1,y2,y3,a,b,c : real; begin write('x1='); readln(x1); write('y1='); readln(y1);
write('x2='); readln(x2); write('y2='); readln(y2); write('x3='); readln(x3); write('y3='); readln(y3); a:=sqrt(sqr(x1-x2)+sqr(y1-y2)); b:=sqrt(sqr(x2-x3)+sqr(y2-y3)); c:=sqrt(sqr(x3-x1)+sqr(y1-y3));writeln('стороны треугольника равны ',a,', ',b,', ',c); end.
-----------------------------------------------------------------------------
3)program нахождениеY;
var
a, b, c, s, k, y: real;
begin
writeln('Введите a.');readln(a);writeln('Введите b.');readln(b);writeln('Введите с.');readln(c);s := (sqrt(a+b*b*b*b*b)/3*c);k := s - sqrt(abs(a*b*c));y := s + k - (s/b*c);writeln(y);
end.
Не нашли ответ?
Похожие вопросы