Помогите пожалуйста!!!!Дан массив, состоящий из целых чисел. Напишите программу, которая подсчитывает количество положительных чисел среди элементов массива. Входные данные Сначала задано число N — количество элементов в массив...

Помогите пожалуйста!!!! Дан массив, состоящий из целых чисел. Напишите программу, которая подсчитывает количество положительных чисел среди элементов массива. Входные данные Сначала задано число N — количество элементов в массиве (1N10000). Далее через пробел записаны N чисел — элементы массива. Массив состоит из целых чисел. Выходные данные Необходимо единственное число - количество положительных элементов в массиве. Примеры: входные данные 5 1 2 3 -1 -4 Выходные данные 3
Гость
Ответ(ы) на вопрос:
Гость
program mas;       const nn=10000; var    m: array[1..nn] of integer;    i,k,n: integer; begin writeln('Введите размерность массива'); readln(n); k:=0; for i:=1 to n do read(m[i]); for i:=1 to n do     if m[i]>0 then k:=k+1; writeln(k); end.
Гость
Pascal: var i,n,kol:longint; a:array[1..10000] of longint; begin readln(n); for i:=1 to n do begin read(a[i]); if a[i]>0 then inc(kol); writeln(kol); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы