Помогите составить программу на языке паскаль Вводится натуральное число Х (Х больше 9). 1. определить, совпадают ли по значению первая и последняя цифры.. например, Ввод: 727 Вывод: Число начинается и заканчивается цифрой 7 В...
Помогите составить программу на языке паскаль
Вводится натуральное число Х (Х>9).
1. определить, совпадают ли по значению первая и последняя цифры..
например, Ввод: 727 Вывод: Число начинается и заканчивается цифрой 7
Ввод 123 Вывод Первая и последняя цифры не совпадают.
Ответ(ы) на вопрос:
Гость
var a,b,c:integer;
begin
write('a = '); readln(a);
b:=a mod 10;
c:=a;
while c>9 do c:=c div 10;
if (a>9)
then if b=c
then writeln('Число начинается и заканчивается цифрой ',c)
else writeln('Первая и последняя цифры не совпадают')
else writeln('Число < 10');
end.
Пример:
a = 65478
Первая и последняя цифры не совпадают
Гость
прога в приложении============
Не нашли ответ?
Похожие вопросы