Пожалуйста помогите! Напишите программу, которая в последовательности целых чисел определяет число отрицательных трехзначных чисел, кратных 3 и оканчивающихся на 6. программа должна вывести одно число - число отрицательное тре...
Пожалуйста помогите!
Напишите программу, которая в последовательности целых чисел определяет число отрицательных трехзначных чисел, кратных 3 и оканчивающихся на 6.
программа должна вывести одно число - число отрицательное трехзначных чисел кратных 6 и оканчивающихся на 3.
Признаком конца ввода чисел - ввод 0.
Пример работы программы:
Входные данные Выходные данные
-186 1
-36
36
186
0
Ответ(ы) на вопрос:
Гость
Var
A,k:integer;
Begin
k:=0;
Read(A);
While A<>0 do
Begin
Read(A);
if (A<-99)and(A>-1000)and(A mod 3 = 0)and(A mod 10 = -6) then
k:=k+1;
End;
WriteLn(k);
End.
Гость
#include
#include
using namespace std;
int main() {
int a, c = 0;
for(cin>>a; a!=0;
c+=(a<0 && !abs(a/1000) && abs(a/100) && !abs(a%3) && abs(a%10)==6),
cin >> a);
cout << c << endl;
Не нашли ответ?
Похожие вопросы