Program ca; var p, i: integer; begin i := 3; p := 1; while i меньше = 23 do begin p := p * i; i := i + 2; end; writeln('p = ', p); end. Говорит что арифметич.переполнение 2задания )Задан массив А [1..5].Составить программу ,ко...
Program ca;
var
p, i: integer;
begin
i := 3;
p := 1;
while i <= 23 do
begin
p := p * i;
i := i + 2;
end;
writeln('p = ', p);
end.
Говорит что арифметич.переполнение
2задания )Задан массив А [1..5].Составить программу ,которая выводит на экран элементы массива в обратном порядке.
3)задания:Задан массив А [1..15].Составить программу ,которая выводит разность суммы элементов массива чётными индексами и элементов массива с нечётными индексами
Ответ(ы) на вопрос:
Гость
Второе:
program o;
var A:array[1..5] of integer; i:integer;
begin;
for i:=1 to 5 do readln(A[i]);
for i:=5 downto 1 do writeln(A[i])
end.
Третье:
program p;
var A:array[1..15] of integer; i,sum1,sum2,res:integer;
begin;
for i:=1 to 15 do read(A[i]);
for i:=1 to 15 do
if i mod 2=0 then sum1:=sum1+A[i] else sum2:=sum2+A[i];
res:=sum1-sum2;
write(res);
end.
Не нашли ответ?
Похожие вопросы