Прошу написать программу для создания чисел, состоящих из двух одинаковых чисел из заданного диапазона. Например: из 210345 и 210345 должно получиться 210345210345 , из 210666 и 210666 - 210666210666 Диапазон - от 100000000000 ...

Прошу написать программу для создания чисел, состоящих из двух одинаковых чисел из заданного диапазона. Например: из 210345 и 210345 должно получиться 210345210345 , из 210666 и 210666 - 210666210666 Диапазон - от 100000000000 до 400000000000 Похожая программа выложена на http://znanija.com/task/7625483 Но там создавались зеркальные числа: 1221, 123321 Благодарю за внимание.
Гость
Ответ(ы) на вопрос:
Гость
// PascalABC.NET 3.1, сборка 1239 от 08.05.2016 begin   Writeln(ReadlnString('Введите исходное число:')*2) end. Тестовое решение Введите исходное число: 210345 210345210345
Гость
Var  a:longint; Begin  write('Введите число: ');  readln(a);  writeln('Вывод: ',a,a) End.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы