Решить задачу в Паскале. С клавиатуры вводится время суток в часах (от 1 до 24). Необходимо составить программу, которая будет выводить на экран привествие согласно введенному времени. Ввод: 1 Вывод: Доброй ночи
Решить задачу в Паскале.
С клавиатуры вводится время суток в часах (от 1 до 24). Необходимо составить программу, которая будет выводить на экран привествие согласно введенному времени.
Ввод:
1
Вывод:
Доброй ночи
Ответ(ы) на вопрос:
program myp;
var a:integer;
begin
readln(a);
if a = 1 then writeln('Доброй ночи');
end.
var
time : Integer; begin
writeln('Введите, который час: ');
readln(time);
if (time > 23) or (time < 0) then
writeln('Так не бывает!') else
begin
if ( time >= 0 ) and ( time < 6 ) then writeln('Доброй ночи!');
if ( time >= 6 ) and ( time < 12 ) then writeln('Доброе утро!');
if ( time >= 12 ) and ( time < 18 ) then writeln('Добрый день!');
if ( time >= 18 ) and ( time < 24 ) then writeln('Добрый вечер!');
end;
end.
Не нашли ответ?
Похожие вопросы