С клавиатуры последовательно вводятся 15 разных целых чисел, которые размещаются ?

С клавиатуры последовательно вводятся 15 разных целых чисел, которые размещаются ?? массиве. Напишите программу, которая выводит на экран количество элементов массива кратных 5 и минимальное среди подходящих под это условие.
Гость
Ответ(ы) на вопрос:
Гость
Const n = 15; var a:array[1..n]of integer; i,m,min5:integer; f:boolean; begin   for i:=1 to n do begin     write('Введите ',i,' член массива ');     readln(a[i]);     if a[i] mod 5=0 then begin       m:=m+1;       if not f then begin         min5:=a[i];         f:= not f;       end;       if (f) and (a[i]<min5) then min5:=a[i];     end;   end;   writeln('Кратных 5: ',m:3,' Минимальный: ',min5:4); end. Тестовое решение Введите 1 член массива 13 Введите 2 член массива 10 Введите 3 член массива 15 Введите 4 член массива 5 Введите 5 член массива 25 Введите 6 член массива 23 Введите 7 член массива 12 Введите 8 член массива 32 Введите 9 член массива 11 Введите 10 член массива 21 Введите 11 член массива 43 Введите 12 член массива 15 Введите 13 член массива 25 Введите 14 член массива 13 Введите 15 член массива 14 Кратных 5:  6    Минимальный:  5
Не нашли ответ?
Ответить на вопрос
Похожие вопросы