Составить программу для решения задачи: Рост 25 учеников класса представлен в виде массива. Определить количество учеников, рост которых больше среднего роста по классу.
Составить программу для решения задачи:
Рост 25 учеников класса представлен в виде массива. Определить количество учеников, рост которых больше среднего роста по классу.
Ответ(ы) на вопрос:
const n = 25;
var
rost : array [1..25] of byte;
count, i : byte;
sum: integer;
begin
randomize;
for i:=1 to 25 do
begin
rost[i]:=random (40) + 150;
inc (sum, rost[i]);
end;
for i:=1 to 25 do
if rost[i]>(sum/n) then inc (count);
write (count);
end.
Не нашли ответ?
Похожие вопросы