Составить программу ,которая формирует массив ,содержащий 12 случайных целых чисел ,принадлежащий промежутку [-7;10],и подсчитывает кол-во всех отрицательный чисел

Составить программу ,которая формирует массив ,содержащий 12 случайных целых чисел ,принадлежащий промежутку [-7;10],и подсчитывает кол-во всех отрицательный чисел
Гость
Ответ(ы) на вопрос:
Гость
#include #include       #include        int main() {   srand(time(NULL));   int a[12];   int s = 0;   for (int i = 0; i < 12; ++i){     a[i] = rand() % 18 - 7;     if (a[i] < 0) s++;   }   std::cout << s;    return 0; }
Гость
Паскаль: var i,t:integer;     a:array[1..12] of integer; begin  randomize;   for i := 1 to 12 do begin     a[i] := round( random(17)-7 );     write(a[i]:3);   end;   t := 0;   for i := 1 to 12 do     if a[i] < 0 then       inc(t);   writeln;   writeln(t);   readln; end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы