Составьте программу для Арифметической прогрессии(для PascalAbc) На втором фото изображен пример как делать,только с другой прогрессией (1/1+1/3+1/5+1/7+1/9=) На первом ,сама прогрессия

Составьте программу для Арифметической прогрессии(для PascalAbc) На втором фото изображен пример как делать,только с другой прогрессией (1/1+1/3+1/5+1/7+1/9=) На первом ,сама прогрессия
Гость
Ответ(ы) на вопрос:
Гость
var n,i:integer; a,s:real; begin write('n='); readln(n); s:=1; a:=1/7; for i:=1 to n do  begin  a:=a*7*7;  s:=s+1/a;  end; writeln('s=',s); end. Пример: n=3 s=1.14583209377045
Не нашли ответ?
Ответить на вопрос
Похожие вопросы