Составьте программу, которая выводит на экран из всех трехзначных чисел только те
Составьте программу, которая выводит на экран из всех трехзначных чисел только те, у которых квадрат первой цифры равен сумме двух остальных.
Ответ(ы) на вопрос:
Var i:integer;
begin
for i:=100 to 999 do
if sqr(i div 100) = i div 10 mod 10 + i mod 10 then writeln(i);
end.
Результат:
101
110
204
213
222
231
240
309
318
327
336
345
354
363
372
381
390
479
488
497
Не нашли ответ?
Похожие вопросы