В массиве из 10 вещественных чисел вычислить среднее арифметическое массива, стоящих левее максимального. Составить программу на языке паскаль. Пожалуйста очень надо.
В массиве из 10 вещественных чисел вычислить среднее арифметическое массива, стоящих левее максимального. Составить программу на языке паскаль. Пожалуйста очень надо.
Ответ(ы) на вопрос:
uses crt;
var
a:array [1..10] of integer;
i,max,k,n:integer; sr:real;
begin
clrscr; randomize; writeln('Массив:');
for i:=1 to 10 do
begin
a[i]:=random(100);
write(a[i],' ');
end;
writeln;
max:=a[1];
for i:=1 to 10 do
if a[i]>max then
begin
max:=a[i];
n:=i;
end;
writeln('Максимальный элемент массива: ',max);
for n:=n+1 to 10 do
begin
sr:=sr+a[n];
k:=k+1;
end;
write('Среднее чисел, стоящих левее максимального: ',(sr/k));
end.
Не нашли ответ?
Похожие вопросы